problème ruban led programmable T-1000S lededit

zoul09
Nouveau membre !!!
Nouveau membre !!!
Messages : 6
Enregistré le : 28 mars 2021, 12:50

problème ruban led programmable T-1000S lededit

Message non lu par zoul09 »

Bonjour, et merci de m'accueillir, je suis tout nouveau, j'espère être au bon endroit pour cette question.

J'ai un projet de programmation d'effets simples sur un ruban led pour un numéro de cirque.
Je suis jongleur amateur, et j'essaie de monter un petit numéro de jonglerie lumineuse (extrait de la première ébauche du numéro en 2019 : https://youtu.be/OQ_di2VwHPA). Je me suis déjà fabriqué des anneaux (https://youtu.be/AKeHMqil18Q) et des massues, lumineuses (https://youtu.be/-J9_d9A4cWk), et le masque lumineux.

J'ai acheté un ruban led programmable (WS2812, 5m, 300 leds total, ip65), une alim JCPOWER JC-150-5 (5v, 30E, 150W) et un contrôleur T-1000S.
L'idée est en premier lieu de faire simplement des effets de défilements de couleurs, de changements de couleurs, si j'arrive à faire ça d'autres effets seront envisagés (type étoile, centre vers extérieur si je fais un style de spirale, ...).
J'ai téléchargé le logiciel Lededit afin de faire un programme pour le contrôleur.
Mais voilà j'ai un gros souci, à chaque fois que je tente une programmation, toutes les leds s'allument en blanc, mais j'ai quand même l'impression qu'il y a légèrement l'effet que j'ai programmé qui tourne en plus. En bref j'ai l'impression que ma programmation est bonne et que j'ai un problème de paramétrage, ou de reconnaissance des matériels, qui fait que ne plus de ma programmation, il y a du blanc.
Pourtant j'ai l'impression de bien faire les choses, j'ai indiqué le contrôleur T-1000, nombre max de leds 300, je dessine un ligne de 300 leds en ''edit layout'' puis je choisi un effet simple que j'enregistre. Et enfin lors de l'export, je choisi WS2812 et je crée le fichier effet en .led, je copie ce .led dans la carte sd que j'insère dans le contrôleur et là, à chaque fois ça fais la même chose, tout en blanc et en arrière plan on a l'impression que l'effet tourne bien quand même, mais évidemment on le voit très peu vu que toutes les leds sont déjà en blanc.
Je précise que les effets préprogrammés dans le contrôleurs fonctionnent très bien, pas de blanc en plus.

Ça fait 1 mois que je galère et que je cherche, que je teste différents trucs, j'ai même essayé de changer le câblage qui pourtant est simple, mais au cas où :
le ruban led à une fiche avec un rouge, blanc, vert et deux fils libres rouge, blanc.
Les deux fils libres ne sont pas branchés, sur la fiche le rouge est branché direct au VCC (3.3-24V) du contrôleur, le vert au data et le blanc au gnd
juste à côté. Le contrôleur est alimenté par le JC-150-5.

Voilà, si quelqu'un a une idée pour m'aider ce serait super, si besoin je peux faire des photos, des vidéos ... mais ça ressemble vraiment à une bétise que je fais lors de la programmation, une histoire de paramètre ou je ne sais quoi.

Je vous remercie beaucoup pour vos réponses, je fabrique pleins de trucs pour ce numéros qui j'espère prendra un jour forme (et qu'on pourra faire la fête de l'association de cirque) et sincèrement j'en ai vraiment marre de galérer avec ça. Ça parait tellement bien comme truc.

A la rigueur si quelqu'un connais bien ce logiciel, et a le même matos, peut-être me filer un fichier .led qu'il ou elle aurait fait pour que je puisse tester et voir déjà si c'est effectivement une erreur dans ma manière d'utiliser le logiciel ou si c'est un problème autre.

Merci encore, au plaisir de vous lire très bientôt

Cyril
commande alibaba.png
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.

Gérard
Rang "6 LEDs"
Rang "6 LEDs"
Messages : 1407
Enregistré le : 12 avr. 2012, 21:58

Re: problème ruban led programmable T-1000S lededit

Message non lu par Gérard »

Bonjour et bienvenu,

Il faudrait des liens vers ton matériel. C'est quoi comme contrôleur?
Quel logiciel permet de faire ce que tu souhaites?

zoul09
Nouveau membre !!!
Nouveau membre !!!
Messages : 6
Enregistré le : 28 mars 2021, 12:50

Re: problème ruban led programmable T-1000S lededit

Message non lu par zoul09 »

Bonjour Gérard, et merci pour ta réponse
et désolé je n'ai pas pu te répondre plaus rapidement, j'étais parti dans les montagnes auvergnate, ça a fait du bien

Le contrôleur est le T-1000S
Le logiciel LEDEDIT
c'est un ruban de WS2812

Gérard
Rang "6 LEDs"
Rang "6 LEDs"
Messages : 1407
Enregistré le : 12 avr. 2012, 21:58

Re: problème ruban led programmable T-1000S lededit

Message non lu par Gérard »

Tu peux mettre des liens?

zoul09
Nouveau membre !!!
Nouveau membre !!!
Messages : 6
Enregistré le : 28 mars 2021, 12:50

Re: problème ruban led programmable T-1000S lededit

Message non lu par zoul09 »

https://fr.aliexpress.com/item/32682015 ... 6c37xrdu5d

https://fr.aliexpress.com/item/32679309 ... 6c37xrdu5d

https://fr.aliexpress.com/item/32593544 ... 6c37xrdu5d

Je pense que le problème vient du logiciel LEDEDIT, ou de son utilsation (j'ai peut-être fait une boulette notamment de paramétrage), ou du boitier contrôleur, mais pour vérifier ça il faudrait que je trouve quelqu'un qui a LEDEDIT et qui pourrais me faire passer un fichier qu'il a fait et qui fonctionne pour que je puisse vérifier d'où vient mon problème.

le lien vers le logiciel :
https://led-edit-effects.com/

Gérard
Rang "6 LEDs"
Rang "6 LEDs"
Messages : 1407
Enregistré le : 12 avr. 2012, 21:58

Re: problème ruban led programmable T-1000S lededit

Message non lu par Gérard »

Bonjour,
Désolé du retard.
Si les LED sont des WS2812B, le contrôleurs sait les piloter mais elles ne sont pas dans la liste du logiciel.

zoul09
Nouveau membre !!!
Nouveau membre !!!
Messages : 6
Enregistré le : 28 mars 2021, 12:50

Re: problème ruban led programmable T-1000S lededit

Message non lu par zoul09 »

Bonsoir Gérard, et merci de répondre c'est vraiment sympa.

Je viens de vérifier dans le logiciel, ces leds sont bien dans le logiciel, au moment de l'export je choisi bien les WS2812 (même ligne que les 2811 et d'autres 28-- ), enfin c'est 2812 sans le B, je pense que c'est la même chose mais peut-être que je me trompe.
Est-ce que tu connais ce logiciel ?
Si je ne peux pas me servir de ce logiciel pour créer le fichier pour le contrôleur T-1000S, comment est-ce que je peux faire pour créer mes effets ? (sachant que l'idée première est de faire une succession de divers effets de défilements pour mon numéro de jonglerie, ce serait génial si j'arrivais déjà à réussir ça, la compréhension et l'apprentissage était un plus qui me semblait accessible mais j'avoue que je perds confiance là)

Merci pour les réponses,
Cyril

Gérard
Rang "6 LEDs"
Rang "6 LEDs"
Messages : 1407
Enregistré le : 12 avr. 2012, 21:58

Re: problème ruban led programmable T-1000S lededit

Message non lu par Gérard »

Malheureusement je ne connais pas ce logiciel et ne te serai d'aucune utilité.
tu devrais demander ailleurs.
Essaie ici https://forums.futura-sciences.com/electronique/ ou là http://www.abcelectronique.com/forum/fo ... ay.php?f=1
Il y a peut-être des gens qui connaissent.

zoul09
Nouveau membre !!!
Nouveau membre !!!
Messages : 6
Enregistré le : 28 mars 2021, 12:50

Re: problème ruban led programmable T-1000S lededit

Message non lu par zoul09 »

Ok, merci pour les liens

Répondre